ProxyManager v2.7.1 Release Notes

Release Date: 2020-04-13 // over 1 year ago
  • โœ‚ This release REMOVES support for PHP 7.4.1 and newer, since
    PHP introduced a major backwards compatibility break in a patch
    ๐Ÿš€ release, rendering lazy-loading of typed properties completely
    non-functioning (see bug 79373 "uninitialized typed property cannot accessed in __get magic method").

    ๐Ÿš€ Please upgrade to 2.8.x ASAP: this release is only here to raise
    โšก๏ธ awareness of the issue in the 2.7.x series, and to make auto-update
    tooling notice it.

    While ocramius/proxy-manager 2.7.1 is compatible with PHP 7.4.0,
    PHP 7.4.1 or newer will require ocramius/proxy-manager 2.8.0 or
    ๐Ÿ†• newer to operate correctly.

    Total issues resolved: 1