All Versions
134
Latest Version
Avg Release Cycle
117 days
Latest Release
242 days ago
Changelog History
Page 6
Changelog History
Page 6
-
v1.7.2 Changes
January 06, 2015๐ฅ BREAKING CHANGES:
- If you depended on the paths that Chef/Puppet provisioners use to
store cookbooks (ex. "/tmp/vagrant-chef-1"), these will no longer be
correct. Without this change, Chef/Puppet didn't work at all with
vagrant provision. We expect this to affect only a minor number of people, since it's not something that was ever documented or recommended by Vagrant, or even meant to be supported.
๐ FEATURES:
- provisioners/salt: add support for grains [GH-4895]
๐ IMPROVEMENTS:
- commands/reload,up:
--provision-withimplies--provision[GH-5085]
๐ BUG FIXES:
- core: private boxes still referencing vagrantcloud.com will have their vagrant login access token properly appended
- core: push plugin configuration is properly validated
- core: restore box packaging functionality
- commands/package: fix crash
- commands/push: push lookups are by user-defined name, not push strategy name [GH-4975]
- commands/push: validate the configuration
- communicators/winrm: detect parse errors in PowerShell and error
- guests/arch: fix network configuration due to poor line breaks. [GH-4964]
- guests/solaris: Merge configurations properly so configs can be set in default Vagrantfiles. [GH-5092]
- installer: SSL cert bundle contains 1024-bit keys, fixing SSL verification for a lot of sites.
- installer: vagrant executable properly
cygpathsthe SSL bundle path for Cygwin - installer: Nokogiri (XML lib used by Vagrant and dependencies) linker dependencies fixed, fixing load issues on some platforms
- providers/docker: Symlinks in shared folders work. [GH-5093]
- providers/hyperv: VM start errors turn into proper Vagrant errors. [GH-5101]
- provisioners/chef: fix missing shared folder error [GH-4988]
- provisioners/chef: remove Chef version check from solo.rb generation and
make
roles_pathpopulate correctly - provisioners/chef: fix bad invocation of
with_clean_env[GH-5021] - pushes/atlas: support more verbose logging
- pushes/ftp: expand file paths relative to the Vagrantfile
- pushes/ftp: improved debugging output
- pushes/ftp: create parent directories if they do not exist on the remote server
- If you depended on the paths that Chef/Puppet provisioners use to
store cookbooks (ex. "/tmp/vagrant-chef-1"), these will no longer be
correct. Without this change, Chef/Puppet didn't work at all with
-
v1.7.1 Changes
December 11, 2014๐ IMPROVEMENTS:
- provisioners/ansible: Use Docker proxy if needed. [GH-4906]
๐ BUG FIXES:
- providers/docker: Add support of SSH agent forwarding. [GH-4905]
-
v1.7.0 Changes
December 09, 2014๐ฅ BREAKING CHANGES:
- provisioners/ansible:
raw_argumentshas now highest priority - provisioners/ansible: only the
sshconnection transport is supported (paramikocan be enabled withraw_argumentsat your own risks)
๐ FEATURES:
- Vagrant Push: Vagrant can now deploy!
vagrant pushis a single command to deploy your application. Deploy to Heroku, FTP, or HashiCorp's commercial product Atlas. New push strategies can be added with plugins. - Named provisioners: Provisioners can now be named. This name is used
for output as well as
--provision-withfor better control. - Default provider logic improved: Providers in
config.vm.providerblocks in your Vagrantfile now have higher priority than plugins. Earlier providers are chosen before later ones. [GH-3812] - If the default insecure keypair is used, Vagrant will automatically replace
it with a randomly generated keypair on first
vagrant up. [GH-2608] - Vagrant Login is now part of Vagrant core
- Chef Zero provisioner: Use Chef 11's "local" mode to run recipes against an in-memory Chef Server
- Chef Apply provisioner: Specify inline Chef recipes and recipe snippets using the Chef Apply provisioner
๐ IMPROVEMENTS:
- core:
has_plugin?function now takes a second argument which is a version constraint requirement. [GH-4650] - core: ".vagrantplugins" file in the same folder as your Vagrantfile will be loaded for defining inline plugins. [GH-3775]
- commands/plugin: Plugin list machine-readable output contains the plugin name as the target for versions and other info. [GH-4506]
- env/with_cleanenv: New helper for plugin developers to use when shelling out to another Ruby environment
- guests/arch: Support predictable network interface naming. [GH-4468]
- guests/suse: Support NFS client install, rsync setup. [GH-4492]
- guests/tinycore: Support changing host names. [GH-4469]
- guests/tinycore: Support DHCP-based networks. [GH-4710]
- guests/windows: Hostname can be set without reboot. [GH-4687]
- providers/docker: Build output is now shown. [GH-3739]
- providers/docker: Can now start containers from private repositories more easily. Vagrant will login for you if you specify auth. [GH-4042]
- providers/docker:
stop_timeoutcan be used to modify thedocker stoptimeout. [GH-4504] - provisioners/chef: Automatically install Chef when using a Chef provisioner.
- provisioners/ansible: Always show Ansible command executed when Vagrant log level is debug (even if ansible.verbose is false)
- synced_folders/nfs: Won't use
sudoto write to /etc/exports if there are write privileges. [GH-2643] - synced_folders/smb: Credentials from one SMB will be copied to the rest. [GH-4675]
๐ BUG FIXES:
- core: Fix cases where sometimes SSH connection would hang.
- core: On a graceful halt, force halt if capability "insert public key" is missing. [GH-4684]
- core: Don't share
/vagrantif any "." folder is shared. [GH-4675] - core: Fix SSH private key permissions more aggressively. [GH-4670]
- core: Custom Vagrant Cloud server URL now respected in more cases.
- core: On downloads, don't continue downloads if the remote server doesn't support byte ranges. [GH-4479]
- core: Box downloads recognize more complex content types that include "application/json" [GH-4525]
- core: If all sub-machines are
autostart: false, don't start any. [GH-4552] - core: Update global-status state in more cases. [GH-4513]
- core: Only delete machine state if the machine is not created in initialize
- commands/box:
--certflag works properly. [GH-4691] - command/docker-logs: Won't crash if container is removed. [GH-3990]
- command/docker-run: Synced folders will be attached properly. [GH-3873]
- command/rsync: Sync to Docker containers properly. [GH-4066]
- guests/darwin: Hostname sets bonjour name and local host name. [GH-4535]
- guests/freebsd: NFS mounting can specify the version. [GH-4518]
- guests/linux: More descriptive error message if SMB mount fails. [GH-4641]
- guests/rhel: Hostname setting on 7.x series works properly. [GH-4527]
- guests/rhel: Installing NFS client works properly on 7.x [GH-4499]
- guests/solaris11: Static IP address preserved after restart. [GH-4621]
- guests/ubuntu: Detect with
lsb_releaseinstead of/etc/issue. [GH-4565] - hosts/windows: RDP client shouldn't map all drives by default. [GH-4534]
- providers/docker: Create args works. [GH-4526]
- providers/docker: Nicer error if package is called. [GH-4595]
- providers/docker: Host IP restriction is forwarded through. [GH-4505]
- providers/docker: Protocol is now honored in direct `ports settings.
- providers/docker: Images built using
build_dirwill more robustly capture the final image. [GH-4598] - providers/docker: NFS synced folders now work. [GH-4344]
- providers/docker: Read the created container ID more robustly.
- providers/docker:
vagrant shareuses correct IP of proxy VM if it exists. [GH-4342] - providers/docker:
vagrant_vagrantfileexpands home directory. [GH-4000] - providers/docker: Fix issue where multiple identical proxy VMs would be created. [GH-3963]
- providers/docker: Multiple links with the same name work. [GH-4571]
- providers/virtualbox: Show a human-friendly error if VirtualBox didn't clean up an existing VM. [GH-4681]
- providers/virtualbox: Detect case when VirtualBox reports 0.0.0.0 as IP address and don't allow it. [GH-4671]
- providers/virtualbox: Show more descriptive error if VirtualBox is reporting an empty version. [GH-4657]
- provisioners/ansible: Force
ssh(OpenSSH) connection by default [GH-3396] - provisioners/ansible: Don't use or modify
~/.ssh/known_hostsfile by default, similarly to native vagrant commands [GH-3900] - provisioners/ansible: Use intermediate Docker host when needed. [GH-4071]
- provisioners/docker: Get GPG key over SSL. [GH-4597]
- provisioners/docker: Search for docker binary in multiple places. [GH-4580]
- provisioners/salt: Highstate works properly with a master. [GH-4471]
- provisioners/shell: Retry getting SSH info a few times. [GH-3924]
- provisioners/shell: PowerShell scripts can have args. [GH-4548]
- synced_folders/nfs: Don't modify NFS exports file if no exports. [GH-4619]
- synced_folders/nfs: Prune exports for file path IDs. [GH-3815]
๐ PLUGIN AUTHOR CHANGES:
Machine#actioncan be called with the optionlock: falseto not acquire a machine lock.Machine#reloadwill now properly trigger themachine_id_changedcallback on providers.
- provisioners/ansible:
-
v1.6.5 Changes
September 04, 2014๐ BUG FIXES:
- core: forward SSH even if WinRM is used. [GH-4437]
- communicator/ssh: Fix crash when pty is enabled with SSH. [GH-4452]
- guests/redhat: Detect various RedHat flavors. [GH-4462]
- guests/redhat: Fix typo causing crash in configuring networks. [GH-4438]
- guests/redhat: Fix typo causing hostnames to not set. [GH-4443]
- providers/virtualbox: NFS works when using DHCP private network. [GH-4433]
- provisioners/salt: Fix error when removing non-existent bootstrap script on Windows. [GH-4614]
-
v1.6.4 Changes
September 02, 2014BACKWARDS INCOMPATIBILITIES:
- commands/docker-run: Started containers are now deleted after run.
Specify the new
--no-rmflag to retain the original behavior. [GH-4327] - providers/virtualbox: Host IO cache is no longer enabled by default since it causes stale file issues. Please enable manually if you require this. [GH-3934]
๐ IMPROVEMENTS:
- core: Added
config.vm.box_server_urlsetting to point at a Vagrant Cloud instance. [GH-4282] - core: File checksumming performance has been improved by at least 100%. Memory requirements have gone down by half. [GH-4090]
- commands/docker-run: Add the
--no-rmflag. Containers are deleted by default. [GH-4327] - commands/plugin: Better error output is shown when plugin installation fails.
- commands/reload: show post up message [GH-4168]
- commands/rsync-auto: Add
--pollflag. [GH-4392] - communicators/winrm: Show stdout/stderr if command fails. [GH-4094]
- guests/nixos: Added better NFS support. [GH-3983]
- providers/hyperv: Accept VHD disk format. [GH-4208]
- providers/hyperv: Support generation 2 VMs. [GH-4324]
- provisioners/docker: More verbose output. [GH-4377]
- provisioners/salt: Get proper exit codes to detect failed runs. [GH-4304]
๐ BUG FIXES:
- core: Downloading box files should resume in more cases since the temporary file is preserved in more cases. [GH-4301]
- core: Windows is not detected as NixOS in some cases. [GH-4302]
- core: Fix encoding issues with Windows. There are still some outlying but this fixes a few. [GH-4159]
- core: Fix crash case when destroying with an invalid provisioner. [GH-4281]
- core: Box names with colons work on Windows. [GH-4100]
- core: Cleanup all temp files. [GH-4103]
- core: User curlrc is not loaded, preventing strange download issues. [GH-4328]
- core: VM names may no longer contain brackets, since they cause issues with some providers. [GH-4319]
- core: Use "-f" to
rmfiles in case pty is true. [GH-4410] - core: SSH key doesn't have to be owned by our user if we're running as root. [GH-4387]
- core: "vagrant provision" will cause "vagrant up" to properly not reprovision. [GH-4393]
- commands/box/add: "Content-Type" header is now case-insensitive when looking for metadata type. [GH-4369]
- commands/docker-run: Named docker containers no longer conflict. [GH-4294]
- commands/package: base package won't crash with exception [GH-4017]
- commands/rsync-auto: Destroyed machines won't raise exceptions. [GH-4031]
- commands/ssh: Extra args are passed through to Docker container. [GH-4378]
- communicators/ssh: Nicer error if remote unexpectedly disconnects. [GH-4038]
- communicators/ssh: Clean error when max sessions is hit. [GH-4044]
- communicators/ssh: Fix many issues around PTY-enabled output parsing. [GH-4408]
- communicators/winrm: Support
mkdir[GH-4271] - communicators/winrm: Properly escape double quotes. [GH-4309]
- communicators/winrm: Detect failed commands that aren't CLIs. [GH-4383]
- guests/centos: Fix issues when NFS client is installed by restarting NFS [GH-4088]
- guests/debian: Deleting default route on DHCP networks can fail. [GH-4262]
- guests/fedora: Fix networks on Fedora 20 with libvirt. [GH-4104]
- guests/freebsd: Rsync install for rsync synced folders work on FreeBSD 10. [GH-4008]
- guests/freebsd: Configure vtnet devices properly [GH-4307]
- guests/linux: Show more verbose error when shared folder mount fails. [GH-4403]
- guests/redhat: NFS setup should use systemd for RH7+ [GH-4228]
- guests/redhat: Detect RHEL 7 (and CentOS) and install Docker properly. [GH-4402]
- guests/redhat: Configuring networks on EL7 works. [GH-4195]
- guests/redhat: Setting hostname on EL7 works. [GH-4352]
- guests/smartos: Use
pfexecfor rsync. [GH-4274] - guests/windows: Reboot after hostname change. [GH-3987]
- hosts/arch: NFS works with latest versions. [GH-4224]
- hosts/freebsd: NFS exports are proper syntax. [GH-4143]
- hosts/gentoo: NFS works with latest versions. [GH-4418]
- hosts/windows: RDP command works without crash. [GH-3962]
- providers/docker: Port on its own will choose random host port. [GH-3991]
- providers/docker: The proxy VM Vagrantfile can be in the same directory as the main Vagrantfile. [GH-4065]
- providers/virtualbox: Increase network device limit to 36. [GH-4206]
- providers/virtualbox: Error if can't detect VM name. [GH-4047]
- provisioners/cfengine: Fix default Yum repo URL. [GH-4335]
- provisioners/chef: Chef client cleanup should work. [GH-4099]
- provisioners/puppet: Manifest file can be a directory. [GH-4169]
- provisioners/puppet: Properly escape facter variables for PowerShell on Windows guests. [GH-3959]
- provisioners/puppet: When provisioning fails, don't repeat all of stdout/stderr. [GH-4303]
- provisioners/salt: Update salt minion version on Windows. [GH-3932]
- provisioners/shell: If args is an array and contains numbers, it no longer crashes. [GH-4234]
- provisioners/shell: If fails, the output/stderr isn't repeated again. [GH-4087]
- commands/docker-run: Started containers are now deleted after run.
Specify the new
-
v1.6.3 Changes
May 29, 2014๐ FEATURES:
- New Guest: NixOS - Supports changing host names and setting networks. [GH-3830]
๐ IMPROVEMENTS:
- core: A CA path can be specified in the Vagrantfile, not just a file, when using a custom CA. [GH-3848]
- commands/box/add:
--capathflag added for custom CA path. [GH-3848] - commands/halt: Halt in reverse order of up, like destroy. [GH-3790]
- hosts/linux: Uses rdesktop to RDP into machines if available. [GH-3845]
- providers/docker: Support for UDP forwarded ports. [GH-3886]
- provisioners/salt: Works on Windows guests. [GH-3825]
๐ BUG FIXES:
- core: Provider plugins more easily are compatible with global-status and should show less stale data. [GH-3808]
- core: When setting a synced folder, it will assume it is not disabled unless explicitly specified. [GH-3783]
- core: Ignore UDP forwarded ports for collision detection. [GH-3859]
- commands/package: Package with
--basefor VirtualBox doesn't crash. [GH-3827] - guests/solaris11: Fix issue with public network and DHCP on newer Solaris releases. [GH-3874]
- guests/windows: Private networks with static IPs work when there is more than one. [GH-3818]
- guests/windows: Don't look up a forwarded port for WinRM if we're not accessing the local host. [GH-3861]
- guests/windows: Fix errors with arg lists that are too long over WinRM in some cases. [GH-3816]
- guests/windows: Powershell exits with proper exit code, fixing
- issues where non-zero exit codes weren't properly detected. [GH-3922]
- hosts/windows: Don't execute mstsc using PowerShell since it doesn't exit properly. [GH-3837]
- hosts/windows: For RDP, don't remove the Tempfile right away. [GH-3875]
- providers/docker: Never do graceful shutdown, always use
docker stop. [GH-3798] - providers/docker: Better error messaging when SSH is not ready direct to container. [GH-3763]
- providers/docker: Don't port map SSH port if container doesn't support SSH. [GH-3857]
- providers/docker: Proper SSH info if using native driver. [GH-3799]
- providers/docker: Verify host VM has SSH ready. [GH-3838]
- providers/virtualbox: On Windows, check
VBOX_MSI_INSTALL_PATHfor VBoxManage path as well. [GH-3852] - provisioners/puppet: Fix setting facter vars with Windows guests. [GH-3776]
- provisioners/puppet: On Windows, run in elevated prompt. [GH-3903]
- guests/darwin: Respect mount options for NFS. [GH-3791]
- guests/freebsd: Properly register the rsync_pre capability
- guests/windows: Certain executed provisioners won't leave output and exit status behind. [GH-3729]
- synced_folders/rsync:
rsync__chowncan be set tofalseto disable recursive chown after sync. [GH-3810] - synced_folders/rsync: Use a proper msys path if not in Cygwin. [GH-3804]
- synced_folders/rsync: Don't append args infinitely, clear out arg list on each run. [GH-3864]
๐ PLUGIN AUTHOR CHANGES:
- Providers can now implement the
rdp_infoprovider capability to get proper info forvagrant rdpto function.
-
v1.6.2 Changes
May 12, 2014๐ IMPROVEMENTS:
- core: Automatically forward WinRM port if communicator is WinRM. [GH-3685]
- command/rdp: Args after "--" are passed directly through to the RDP client. [GH-3686]
- providers/docker:
build_argsconfig to specify extra args fordocker build. [GH-3684] - providers/docker: Can specify options for the build dir synced folder when a host VM is in use. [GH-3727]
- synced_folders/nfs: Can tell Vagrant not to handle exporting
by setting
nfs_export: false[GH-3636]
๐ BUG FIXES:
- core: Hostnames can be one character. [GH-3713]
- core: Don't lock machines on SSH actions. [GH-3664]
- core: Fixed crash when adding a box from Vagrant Cloud that was the same name as a real directory. [GH-3732]
- core: Parallelization is more stable, doesn't crash due to to bad locks. [GH-3735]
- commands/package: Don't double included files in package. [GH-3637]
- guests/linux: Rsync chown ignores symlinks. [GH-3744]
- provisioners/shell: Fix shell provisioner config validation when the
binaryoption is set to false [GH-3712] - providers/docker: default proxy VM won't use HGFS [GH-3687]
- providers/docker: fix container linking [GH-3719]
- providers/docker: Port settings expose to host properly. [GH-3723]
- provisioners/puppet: Separate module paths with ';' on Windows. [GH-3731]
- synced_folders\rsync: Copy symlinks as real files. [GH-3734]
- synced_folders/rsync: Remove non-portable '-v' flag from chown. [GH-3743]
-
v1.6.1 Changes
May 07, 2014๐ IMPROVEMENTS:
- New guest: Linux Mint is now properly detected. [GH-3648]
๐ BUG FIXES:
- core: Global control works from directories that don't have a Vagrantfile.
- core: Plugins that define config methods that collide with Ruby Kernel/Object
- methods are merged properly. [GH-3670]
- commands/docker-run:
--helpworks. [GH-3698] - commands/package:
--baseworks without crashing for VirtualBox. - commands/reload: If
--provisionis specified, force provisioning. [GH-3657] - guests/redhat: Fix networking issues with CentOS. [GH-3649]
- guests/windows: Human error if WinRM not in use to configure networks. [GH-3651]
- guests/windows: Puppet exit code 2 doesn't cause Windows to raise an error. [GH-3677]
- providers/docker: Show proper error message when on Linux. [GH-3654]
- providers/docker: Proxy VM works properly even if default provider environmental variable set to "docker" [GH-3662]
- providers/docker: Put sync folders in
/var/lib/dockerbecause it usually has disk space. [GH-3680] - synced_folders/rsync: Create the directory before syncing.
-
v1.6.0 Changes
May 06, 2014BACKWARDS INCOMPATIBILITIES:
- Deprecated:
halt_timeoutandhalt_check_intervalsettings for SmartOS, Solaris, and Solaris11 guests. These will be fully removed in 1.7. A warning will be shown if they're in use in 1.6.
๐ FEATURES:
- New guest: Windows. Vagrant now fully supports Windows as a guest VM. WinRM can be used for communication (or SSH), and the shell provisioner, Chef, and Puppet all work with Windows VMs.
- New command: global-status. This command shows the state of every created Vagrant environment on the system for that logged in user.
- New command: rdp. This command connects to the running machine via the Remote Desktop Protocol.
- New command: version. This outputs the currently installed version as well as the latest version of Vagrant available.
- New provider: Docker. This provider will back your development environments with Docker containers. If you're not on Linux, it will automatically spin up a VM for you on any provider. You can even specify a specific Vagrantfile to use as the Docker container host.
- Control Vagrant environments from any directory. Using the UUIDs given
in
vagrant global-status, you can issue commands from anywhere on your machine, not just that environment's directory. Example:vagrant destroy UUIDfrom anywhere. - Can now specify a
post_up_messagein your Vagrantfile that is shown after avagrant up. This is useful for putting some instructions of how to use the development environment. - Can configure provisioners to run "once" or "always" (defaults to "once"),
so that subsequent
vagrant uporreloadcalls will always run a provisioner. [GH-2421] - Multi-machine environments can specify an "autostart" option (default
to true).
vagrant upstarts all machines that have enabled autostart. - Vagrant is smarter about choosing a default provider. If
VAGRANT_DEFAULT_PROVIDERis set, it still takes priority, but otherwise Vagrant chooses a "best" provider.
๐ IMPROVEMENTS:
- core: Vagrant locks machine access to one Vagrant process at a time.
This will protect against two simultaneous
upactions happening on the same environment. - core: Boxes can be compressed with LZMA now as well.
- commands/box/remove: Warns if the box appears to be in use by an
environment. Can be forced with
--force. - commands/destroy: Exit codes changes. 0 means everything succeeded. 1 means everything was declined. 2 means some were declined. [GH-811]
- commands/destroy: Doesn't require box to exist anymore. [GH-1629]
- commands/init: force flag. [GH-3564]
- commands/init: flag for minimal Vagrantfile creation (no comments). [GH-3611]
- commands/rsync-auto: Picks up and syncs provisioner folders if provisioners are backed by rsync.
- commands/rsync-auto: Detects when new synced folders were added and warns
user they won't be synced until
vagrant reload. - commands/ssh-config: Works without a target in multi-machine envs [GH-2844]
- guests/freebsd: Support for virtio interfaces. [GH-3082]
- guests/openbsd: Support for virtio interfaces. [GH-3082]
- guests/redhat: Networking works for upcoming RHEL7 release. [GH-3643]
- providers/hyperv: Implement
vagrant ssh -csupport. [GH-3615] - provisioners/ansible: Support for Ansible Vault. [GH-3338]
- provisioners/ansible: Show Ansible command executed. [GH-3628]
- provisioners/salt: Colorize option. [GH-3603]
- provisioners/salt: Ability to specify log level. [GH-3603]
- synced_folders: nfs: Improve sudo commands used to make them sudoers friendly. Examples in docs. [GH-3638]
๐ BUG FIXES:
- core: Adding a box from a network share on Windows works again. [GH-3279]
- commands/plugin/install: Specific versions are now locked in.
- commands/plugin/install: If insecure RubyGems.org is specified as a source, use that. [GH-3610]
- commands/rsync-auto: Interrupt exits properly. [GH-3552]
- commands/rsync-auto: Run properly on Windows. [GH-3547]
- communicators/ssh: Detect if
config.ssh.shellis invalid. [GH-3040] - guests/debian: Can set hostname if hosts doesn't contain an entry already for 127.0.1.1 [GH-3271]
- guests/linux: For
read_ip_addresscapability, setLANG=enso it works on international systems. [GH-3029] - providers/virtualbox: VirtualBox detection works properly again on
Windows when the
VBOX_INSTALL_PATHhas multiple elements. [GH-3549] - providers/virtualbox: Forcing MAC address on private network works properly again. [GH-3588]
- provisioners/chef-solo: Fix Chef version checking to work with prerelease versions. [GH-3604]
- provisioners/salt: Always copy keys and configs on provision. [GH-3536]
- provisioners/salt: Install args should always be present with bootstrap.
- provisioners/salt: Overwrite keys properly on subsequent provisions [GH-3575]
- provisioners/salt: Bootstrap uses raw GitHub URL rather than subdomain. [GH-3583]
- synced_folders/nfs: Acquires a process-level lock so exports don't collide with Vagrant running in parallel.
- synced_folders/nfs: Implement usability check so that hosts that don't support NFS get an error earlier. [GH-3625]
- synced_folders/rsync: Add UserKnownHostsFile option to not complain. [GH-3511]
- synced_folders/rsync: Proxy command is used properly if set. [GH-3553]
- synced_folders/rsync: Owner/group settings are respected. [GH-3544]
- synced_folders/smb: Passwords with symbols work. [GH-3642]
๐ PLUGIN AUTHOR CHANGES:
- New host capability: "rdp_client". This capability gets the RDP connection info and must launch the RDP client on the system.
- core: The "Call" middleware now merges the resulting middleware stack into the current stack, rather than running it as a separate stack. The result is that ordering is preserved.
- core: The "Message" middleware now takes a "post" option that will output the message on the return-side of the middleware stack.
- core: Forwarded port collision repair works when Vagrant is run in parallel with other Vagrant processes. [GH-2966]
- provider: Providers can now specify that boxes are optional. This lets
you use the provider without a
config.vm.box. Useful for providers like AWS or Docker. - provider: A new class-level
usable?method can be implemented on the provider implementation. This returns or raises an error when the provider is not usable (i.e. VirtualBox isn't installed for VirtualBox) - synced_folders: New "disable" method for removing synced folders from a running machine.
- Deprecated:
-
v1.5.4 Changes
April 21, 2014๐ IMPROVEMENTS:
- commands/box/list: Doesn't parse Vagrantfile. [GH-3502]
- providers/hyperv: Implement the provision command. [GH-3494]
๐ BUG FIXES:
- core: Allow overriding of the default SSH port. [GH-3474]
- commands/box/remove: Make output nicer. [GH-3470]
- commands/box/update: Show currently installed version. [GH-3467]
- command/rsync-auto: Works properly on Windows.
- guests/coreos: Fix test for Docker daemon running.
- guests/linux: Fix test for Docker provisioner whether Docker is running.
- guests/linux: Fix regression where rsync owner/group stopped working. [GH-3485]
- provisioners/docker: Fix issue where we weren't waiting for Docker to properly start before issuing commands. [GH-3482]
- provisioners/shell: Better validation of master config path, results in no more stack traces at runtime. [GH-3505]